aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf-archive
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-09-07 10:29:49 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-13 22:53:41 +0100
commita1527207b8f23d4084a18e988605fd30c5e72ca8 (patch)
treec0d002c798c2a85370776162f4441602135e9baf /tools/autoconf-archive
parent129be247a6a0cb11132691bdf27104f48ab08530 (diff)
downloadupstream-a1527207b8f23d4084a18e988605fd30c5e72ca8.tar.gz
upstream-a1527207b8f23d4084a18e988605fd30c5e72ca8.tar.bz2
upstream-a1527207b8f23d4084a18e988605fd30c5e72ca8.zip
tools/autoconf-archive: clean up build recipes
The configure option datarootdir defaults to PREFIX/share. The Host/Clean define should be Host/Uninstall otherwise it is removing the build directory before there is a chance to try "make uninstall" in that directory. Host/Clean/Default is no longer defined. Use default build recipes defined in host-build.mk instead of custom ones that are equivalent. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools/autoconf-archive')
-rw-r--r--tools/autoconf-archive/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/tools/autoconf-archive/Makefile b/tools/autoconf-archive/Makefile
index 228a27cf60..ecca997313 100644
--- a/tools/autoconf-archive/Makefile
+++ b/tools/autoconf-archive/Makefile
@@ -9,20 +9,8 @@ PKG_HASH:=e8a6eb9d28ddcba8ffef3fa211653239e9bf239aba6a01a6b7cfc7ceaec69cbd
include $(INCLUDE_DIR)/host-build.mk
-HOST_CONFIGURE_ARGS += \
- --datarootdir=$(STAGING_DIR_HOST)/share
-
-define Host/Compile
- export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
- export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
- -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
- $(call Host/Clean/Default)
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
endef
$(eval $(call HostBuild))