aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-03-28 18:40:30 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2022-05-18 13:32:06 +0300
commitad79b92719498afa93567cccdfbffeb49a57388d (patch)
treeed9964683f4a24f9f33da06619a65a914a94c104 /tools/Makefile
parentd5dc6cdc536277ce1831acce92dc1cbdc59e7250 (diff)
downloadupstream-ad79b92719498afa93567cccdfbffeb49a57388d.tar.gz
upstream-ad79b92719498afa93567cccdfbffeb49a57388d.tar.bz2
upstream-ad79b92719498afa93567cccdfbffeb49a57388d.zip
elfutils: move host build to tools
The upcoming dwarves host package requires elfutils. As dependencies for tools must exist in tools, we need to move elfutils host build there. As there is at least one package that depends on this, and there is no proper way to create such dependency in the build system, build it unconditionally when not building on macOS. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index ec382b4122..416039cf38 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -83,6 +83,9 @@ ifneq ($(HOST_OS),Linux)
endif
ifeq ($(HOST_OS),Darwin)
tools-y += bash
+else
+ $(curdir)/elfutils/compile := $(curdir)/zlib/compile
+ tools-y += elfutils
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)