aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2023-01-13 10:50:30 +0100
committerOlliver Schinagl <oliver@schinagl.nl>2023-01-17 21:01:54 +0100
commit62e150949fc01ae2327207fa98fae9c5cff6035c (patch)
tree0aa578f4e0c8ed504566474e763b28cdb04f58ed /tools/Makefile
parent9a59bf35281a89e2a783127f16647d4fc07fcf7a (diff)
downloadupstream-62e150949fc01ae2327207fa98fae9c5cff6035c.tar.gz
upstream-62e150949fc01ae2327207fa98fae9c5cff6035c.tar.bz2
upstream-62e150949fc01ae2327207fa98fae9c5cff6035c.zip
libdeflate: Avoid circular dependencies
CMake depends on (libdeflate-)gunzip, libdeflate depends on Cmake, so we can't win. Luckily libdeflate is _very_ easy to build, without any build system, so lets just manually compile it and be done with it. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 7ca874aa91..7b3a8eb142 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -42,7 +42,6 @@ tools-y += findutils
tools-y += firmware-utils
tools-y += flex
tools-y += gengetopt
-tools-y += libdeflate
tools-y += libressl
tools-y += libtool
tools-y += lzma
@@ -98,7 +97,6 @@ $(curdir)/genext2fs/compile := $(curdir)/libtool/compile
$(curdir)/gengetopt/compile := $(curdir)/libtool/compile
$(curdir)/gmp/compile := $(curdir)/libtool/compile
$(curdir)/isl/compile := $(curdir)/gmp/compile
-$(curdir)/libdeflate/compile := $(curdir)/cmake/compile
$(curdir)/liblzo/compile := $(curdir)/cmake/compile
$(curdir)/libressl/compile := $(curdir)/pkgconf/compile
$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/missing-macros/compile
@@ -148,6 +146,7 @@ $(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(
$(foreach tool, $(filter-out xz,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/xz/compile))
# make any tool depend on the following to ensure that archives can be unpacked and patched properly
+tools-core += libdeflate
tools-core += patch
tools-core += tar
tools-core += xz