aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-24 16:57:40 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-29 19:33:17 +0200
commit3848cf458ef998fc9971edd6a01cc9cdb43fbef9 (patch)
treef0fa3d5fa71d9e98fb0bf0c920cfdba502815507 /tools/Makefile
parent89df3589e6237e5ad9b5cdd9f87c82987b200e37 (diff)
downloadupstream-3848cf458ef998fc9971edd6a01cc9cdb43fbef9.tar.gz
upstream-3848cf458ef998fc9971edd6a01cc9cdb43fbef9.tar.bz2
upstream-3848cf458ef998fc9971edd6a01cc9cdb43fbef9.zip
tools/cmake: Build without some included libs
Saves a little bit of time when compiling cmake. Added patches to fix searching liblzma and zlib. The issue is that because pkgconfig is not used, the system libraries get used. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 78fc125ecf..e384136ee9 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -45,7 +45,7 @@ $(curdir)/b43-tools/compile := $(curdir)/bison/compile
$(curdir)/bc/compile := $(curdir)/bison/compile $(curdir)/libtool/compile
$(curdir)/bison/compile := $(curdir)/flex/compile
$(curdir)/cbootimage/compile += $(curdir)/automake/compile
-$(curdir)/cmake/compile += $(curdir)/libressl/compile $(curdir)/ninja/compile
+$(curdir)/cmake/compile += $(curdir)/libressl/compile $(curdir)/ninja/compile $(curdir)/expat/compile $(curdir)/xz/compile $(curdir)/zlib/compile $(curdir)/zstd/compile
$(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
$(curdir)/e2fsprogs/compile := $(curdir)/libtool/compile
$(curdir)/fakeroot/compile := $(curdir)/libtool/compile
@@ -90,9 +90,9 @@ else
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out zstd zlib xz pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out zstd zlib xz pkgconf patch ninja meson libressl expat cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
-$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
+$(curdir)/ccache/compile := $(curdir)/cmake/compile
endif
# in case there is no patch tool on the host we need to make patch tool a