aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-04-18 15:22:48 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-04-18 15:22:48 +0200
commitb691362d1dbe2c07e83c3e703f093dfd8e14145c (patch)
treea7bfb9eb1eae441cb790b40799bedc04f23bb2bd /tools/Makefile
parentf7f47b1369917273b5a21a9fbacfaea80c60c16d (diff)
downloadupstream-b691362d1dbe2c07e83c3e703f093dfd8e14145c.tar.gz
upstream-b691362d1dbe2c07e83c3e703f093dfd8e14145c.tar.bz2
upstream-b691362d1dbe2c07e83c3e703f093dfd8e14145c.zip
Revert "tools/bzip2: add `bzip2` binaries"
This reverts commit 394d7134ec42f14ddb91769c737098753fa68266. The commit has unintentded change that cause compilation error with SDK or LZO compression. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 251ca2c460..bdd9f0a257 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -20,9 +20,6 @@ endif
ifneq ($(CONFIG_SDK)$(CONFIG_PACKAGE_kmod-b43)$(CONFIG_BRCMSMAC_USE_FW_FROM_WL),)
BUILD_B43_TOOLS = y
endif
-ifneq ($(CONFIG_SDK)$(CONFIG_TARGET_INITRAMFS_COMPRESSION_BZIP2),)
- BUILD_BZIP2_TOOLS = y
-endif
ifneq ($(CONFIG_SDK)$(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZ4),)
BUILD_LZ4_TOOLS = y
endif
@@ -67,8 +64,8 @@ tools-y += sstrip
tools-y += zip
tools-y += zlib
tools-y += zstd
+tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS),y) += liblzo
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_B43_TOOLS),y) += b43-tools
-tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_BZIP2_TOOLS),y) += bzip2
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_ISL),y) += isl
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_LZ4_TOOLS),y) += lz4
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_LZO_TOOLS),y) += lzop