aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorTony Butler <spudz76@gmail.com>2022-11-28 17:06:46 -0800
committerDaniel Golle <daniel@makrotopia.org>2023-01-16 23:51:10 +0000
commit9a8509c2c572a29aec28b6b10da12c5d7a1efba8 (patch)
treeb02fa0cfbbef4795171bbdfc44865ebcdab14a3b /tools/Makefile
parent8b12966d20bf10316752b3678d3999f83e564c60 (diff)
downloadupstream-9a8509c2c572a29aec28b6b10da12c5d7a1efba8.tar.gz
upstream-9a8509c2c572a29aec28b6b10da12c5d7a1efba8.tar.bz2
upstream-9a8509c2c572a29aec28b6b10da12c5d7a1efba8.zip
tools/liblzo: add `liblzo` library
prerequisite of upcoming `tools/lzop` addition, and subsequent initramfs and squashfs cleanups same as `packages/lzo` modified to be a HOST/tools type build, and should always be the same version and sources when either one is bumped because this (and `packages/lzo`) only provide liblzo and no executables, use the clearer name `tools/liblzo` Signed-off-by: Tony Butler <spudz76@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 46283e8d81..67b09f3a80 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -62,6 +62,7 @@ tools-y += sstrip
tools-y += zip
tools-y += zlib
tools-y += zstd
+tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS),y) += liblzo
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_B43_TOOLS),y) += b43-tools
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_ISL),y) += isl
tools-$(if $(CONFIG_BUILD_ALL_HOST_TOOLS)$(BUILD_LZ4_TOOLS),y) += lz4
@@ -94,6 +95,7 @@ $(curdir)/gengetopt/compile := $(curdir)/libtool/compile
$(curdir)/gmp/compile := $(curdir)/libtool/compile
$(curdir)/isl/compile := $(curdir)/gmp/compile
$(curdir)/libdeflate/compile := $(curdir)/cmake/compile
+$(curdir)/liblzo/compile := $(curdir)/cmake/compile
$(curdir)/libressl/compile := $(curdir)/pkgconf/compile
$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/missing-macros/compile
$(curdir)/lzma-old/compile := $(curdir)/zlib/compile