aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-25 00:22:24 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-21 00:38:36 +0100
commite453767535edd27aabb45038c967fab98fcc2d58 (patch)
tree81e5509fce4068ba8cb5823ae2e880887f6ec5a7 /tools/Makefile
parent3e511a7a23215d4a986c876db28bef9beab42b70 (diff)
downloadupstream-e453767535edd27aabb45038c967fab98fcc2d58.tar.gz
upstream-e453767535edd27aabb45038c967fab98fcc2d58.tar.bz2
upstream-e453767535edd27aabb45038c967fab98fcc2d58.zip
tools/zlib: switch to configure script
A future commit will make tools/cmake use this. Signed-off-by: Rosen Penev <rosenp@gmail.com> (cherry picked from commit d602e7a969922121800e8f24d81cecdaab3aae75)
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index c18c2b4242..57a6530ba4 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -74,7 +74,6 @@ $(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compil
$(curdir)/sdcc/compile := $(curdir)/bison/compile
$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
$(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
-$(curdir)/zlib/compile := $(curdir)/cmake/compile
$(curdir)/zstd/compile := $(curdir)/meson/compile
ifneq ($(HOST_OS),Linux)
@@ -86,7 +85,7 @@ ifeq ($(HOST_OS),Darwin)
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out zstd zlib xz pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
endif