aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-22 01:43:43 -0800
committerFelix Fietkau <nbd@nbd.name>2021-11-22 12:00:40 +0100
commit340c2ed2ef6578483f974e274bf6d638f953a246 (patch)
tree8b4cc72d444b7cea21cbded25901535d506ab4a4 /tools/Makefile
parent8f458498768ab164d5e42becca52624448dfe2ee (diff)
downloadupstream-340c2ed2ef6578483f974e274bf6d638f953a246.tar.gz
upstream-340c2ed2ef6578483f974e274bf6d638f953a246.tar.bz2
upstream-340c2ed2ef6578483f974e274bf6d638f953a246.zip
tools/llvm-bpf: move tarball packing to target/llvm-bpf
This ensures that the tarball is regenerated after make clean or after switching to a different target Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 82a67a00dd..686d5294d3 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -156,8 +156,7 @@ $(curdir)/ := .config prereq
$(curdir)/install: $(curdir)/compile
-tools_config = CONFIG_SDK_LLVM_BPF
-tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))$(foreach c,$(tools_config),$(if $($(c)),y,n))
+tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))
$(eval $(call stampfile,$(curdir),tools,compile,,_$(subst $(space),,$(tools_enabled)),$(STAGING_DIR_HOST)))
$(eval $(call stampfile,$(curdir),tools,check,$(TMP_DIR)/.build,,$(STAGING_DIR_HOST)))
$(eval $(call subdir,$(curdir)))