aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-06-18 19:53:17 -0700
committerPaul Spooren <mail@aparcar.org>2021-09-16 16:31:28 -1000
commitaa344bcfa86264f74513d11c780f5612481d1c99 (patch)
tree220e74d0f13c7eb3521845080a12a4cec722f87f /tools/Makefile
parentc4dfdde2eaa399025de1032bed8ee8a5f8babb24 (diff)
downloadupstream-aa344bcfa86264f74513d11c780f5612481d1c99.tar.gz
upstream-aa344bcfa86264f74513d11c780f5612481d1c99.tar.bz2
upstream-aa344bcfa86264f74513d11c780f5612481d1c99.zip
tools/pkgconf: update to 1.8.0
Switch to compiling with meson for faster and more reliable compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index e16af6c68f..f794e57f2e 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -66,6 +66,7 @@ $(curdir)/mpfr/compile := $(curdir)/gmp/compile
$(curdir)/mtd-utils/compile := $(curdir)/libtool/compile $(curdir)/e2fsprogs/compile $(curdir)/zlib/compile
$(curdir)/padjffs2/compile := $(curdir)/findutils/compile
$(curdir)/patchelf/compile := $(curdir)/libtool/compile
+$(curdir)/pkgconf/compile := $(curdir)/meson/compile
$(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compile
$(curdir)/sdcc/compile := $(curdir)/bison/compile
$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
@@ -79,7 +80,7 @@ ifneq ($(HOST_OS),Linux)
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out xz zstd patch pkgconf libressl ninja cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out xz zstd pkgconf patch ninja meson libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
$(curdir)/ccache/compile := $(curdir)/zstd/compile
endif