aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-21 12:13:52 +0100
committerFelix Fietkau <nbd@nbd.name>2021-11-21 13:47:18 +0100
commit848499c1cf2c55adf8f3e0e355caa07234803cbe (patch)
tree877a61a62cf1d8d0eec11a3bd4ac1d2bff4039b2 /tools/Makefile
parent9b29c14b0eeaf5c22b28b740c8abce76befbc988 (diff)
downloadupstream-848499c1cf2c55adf8f3e0e355caa07234803cbe.tar.gz
upstream-848499c1cf2c55adf8f3e0e355caa07234803cbe.tar.bz2
upstream-848499c1cf2c55adf8f3e0e355caa07234803cbe.zip
tools: include the value of CONFIG_SDK_LLVM_BPF in the stampfile
tools/llvm-bpf needs to be checked if the value changes Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 686d5294d3..82a67a00dd 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -156,7 +156,8 @@ $(curdir)/ := .config prereq
$(curdir)/install: $(curdir)/compile
-tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))
+tools_config = CONFIG_SDK_LLVM_BPF
+tools_enabled = $(foreach tool,$(sort $(tools-y) $(tools-)),$(if $(filter $(tool),$(tools-y)),y,n))$(foreach c,$(tools_config),$(if $($(c)),y,n))
$(eval $(call stampfile,$(curdir),tools,compile,,_$(subst $(space),,$(tools_enabled)),$(STAGING_DIR_HOST)))
$(eval $(call stampfile,$(curdir),tools,check,$(TMP_DIR)/.build,,$(STAGING_DIR_HOST)))
$(eval $(call subdir,$(curdir)))