aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-02-28 19:26:07 +0000
committerRafał Miłecki <rafal@milecki.pl>2022-03-15 18:50:26 +0100
commit17e95532842c4d62b30669490eb00b39cf8ff743 (patch)
tree948f394679c76d03b0066afde498330b401a87a1 /tools/Makefile
parentf44f8b07b0277d38fafb3d613a303454d3b9faaf (diff)
downloadupstream-17e95532842c4d62b30669490eb00b39cf8ff743.tar.gz
upstream-17e95532842c4d62b30669490eb00b39cf8ff743.tar.bz2
upstream-17e95532842c4d62b30669490eb00b39cf8ff743.zip
tools: add xxd (from vim)
U-Boot requires xxd to create the default environment from an external file as done in uboot-mediatek. Build xxd (only, not the rest of vim) as part of tools to make sure it is present on the buildhost. Reported-by: David Bauer <mail@david-bauer.net> Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit c4dd2441e7875c9550820f8380b3e41ca619ef27)
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index a2665dbc9a..577ea799c5 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -25,7 +25,7 @@ tools-y += autoconf autoconf-archive automake bc bison cmake dosfstools
tools-y += e2fsprogs fakeroot findutils firmware-utils flex gengetopt
tools-y += libressl libtool lzma m4 make-ext4fs missing-macros mkimage
tools-y += mklibs mm-macros mtd-utils mtools padjffs2 patch-image
-tools-y += patchelf pkgconf quilt squashfskit4 sstrip zip zlib zstd
+tools-y += patchelf pkgconf quilt squashfskit4 sstrip xxd zip zlib zstd
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_ISL) += isl
tools-$(BUILD_TOOLCHAIN) += expat gmp libelf mpc mpfr