aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
commit1b88b67b0950c219e9059b45635aa60c889beef3 (patch)
treec8a6a0f65801669d0749e819d2c5cc4ae410076e /tools/Makefile
parent5a344daff13f805b882f38b9dd2cef64cc6ff116 (diff)
downloadupstream-1b88b67b0950c219e9059b45635aa60c889beef3.tar.gz
upstream-1b88b67b0950c219e9059b45635aa60c889beef3.tar.bz2
upstream-1b88b67b0950c219e9059b45635aa60c889beef3.zip
build system fixes, more cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8207 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 49b30be44b..ed2eae89d9 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -7,25 +7,25 @@
# Main makefile for the host tools
#
-curdir:=$(patsubst %/Makefile,%,$(lastword $(MAKEFILE_LIST)))
+curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
+tools/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
# builddir dependencies
-$(curdir)/squashfs/compile := $(curdir)/lzma/install
+tools/squashfs/compile := tools/lzma/install
# preparatory work
$(STAGING_DIR)/include-host/.done:
@mkdir -p $$(dirname $@)
- @cp $(curdir)/include/*.h $$(dirname $@)/
+ @cp tools/include/*.h $$(dirname $@)/
@touch $@
# prerequisites for the individual targets
-$(curdir)/ := .config
-$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
-$(curdir)//compile = $(1)/prepare
-$(curdir)//install = $(1)/compile
+tools/ := .config
+tools//prepare = $(STAGING_DIR)/include-host/.done
+tools//compile = $(1)/prepare
+tools//install = $(1)/compile
-$(eval $(call stampfile,$(curdir),tools))
-$(eval $(call subdir,$(curdir)))
+$(eval $(call stampfile,tools,tools))
+$(eval $(call subdir,tools))