aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-20 16:18:08 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-20 16:18:08 +0000
commit919f5d8ee53f430be11637c61f479cf4992ca839 (patch)
treeb31b36336f28314dd72c28852b1dcf5f76f62905 /tools/Makefile
parent6edd065384aff0d9b7aba8205d5df441d9b21e29 (diff)
downloadupstream-919f5d8ee53f430be11637c61f479cf4992ca839.tar.gz
upstream-919f5d8ee53f430be11637c61f479cf4992ca839.tar.bz2
upstream-919f5d8ee53f430be11637c61f479cf4992ca839.zip
[toolchain] fix graphite options with gcc-4.5, add libelf for LTO, fix mbsd_multi patch, patch from Bernhard Loos
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21046 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/tools/Makefile b/tools/Makefile
index cad5011c30..a173722ad2 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -11,11 +11,8 @@ curdir:=tools
# subdirectories to descend into
tools-y :=
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
-ifeq ($(CONFIG_GCC_VERSION_4_5),y)
-tools-$(CONFIG_GCC_VERSION_4_5) += gmp mpfr mpc
-else
-tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
-endif
+tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4)$(CONFIG_GCC_VERSION_4_5) += gmp mpfr
+tools-$(CONFIG_GCC_VERSION_4_5) += mpc libelf
endif
tools-y += m4 autoconf automake bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
@@ -32,8 +29,10 @@ endif
tools-$(CONFIG_CCACHE) += ccache
ifdef CONFIG_GCC_USE_GRAPHITE
- tools-y += ppl cloog
- $(curdir)/cloog/compile := $(curdir)/ppl/install
+ ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
+ tools-y += ppl cloog
+ $(curdir)/cloog/compile := $(curdir)/ppl/install
+ endif
endif
# builddir dependencies