aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-15 20:25:29 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-15 20:25:29 +0000
commitf87c3cbb3adcb45c6d0b414361107e866591aee7 (patch)
treecb7c28ae5e1b26c6ad48dc42865f02ab9491a84b /tools/Makefile
parent194f32bc260ffe5261fbf9f191b5c10008565854 (diff)
downloadupstream-f87c3cbb3adcb45c6d0b414361107e866591aee7.tar.gz
upstream-f87c3cbb3adcb45c6d0b414361107e866591aee7.tar.bz2
upstream-f87c3cbb3adcb45c6d0b414361107e866591aee7.zip
make the lzma version kernel version dependent, and only build the one we do need
SVN-Revision: 18426
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index b7c7f43db6..e3e26f3c4f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -14,11 +14,15 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
endif
tools-y += m4 autoconf automake bison pkg-config sed mklibs
-tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
+tools-y += sstrip ipkg-utils genext2fs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_28),)
+tools-y += squashfs lzma-old
+else
+tools-y += squashfs4 lzma
+endif
tools-$(CONFIG_CCACHE) += ccache
-tools-dep += lzma
ifdef CONFIG_GCC_USE_GRAPHITE
tools-y += ppl cloog