aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-26 13:02:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-26 13:02:35 +0000
commitf4a3dfc4be57b98378b8ce071c25adc1237764be (patch)
tree8934dfe4c248e6ae499a82c20b17f566020b7283 /tools/Makefile
parentb936bd8c3bfa43779ddab78f3e637791c8349995 (diff)
downloadupstream-f4a3dfc4be57b98378b8ce071c25adc1237764be.tar.gz
upstream-f4a3dfc4be57b98378b8ce071c25adc1237764be.tar.bz2
upstream-f4a3dfc4be57b98378b8ce071c25adc1237764be.zip
tools: drop circular dependency between patch and ccache, build patch without ccache (fixes #20132)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> Backport of r46434 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46498 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 2f516d2383..d2fe2ffddf 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -73,7 +73,7 @@ $(curdir)/gengetopt/compile := $(curdir)/libtool/install
$(curdir)/patchelf/compile := $(curdir)/libtool/install
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
+$(foreach tool, $(filter-out patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
tools-y += ccache
endif