aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2012-10-08 20:15:42 +0000
committerHauke Mehrtens <hauke@openwrt.org>2012-10-08 20:15:42 +0000
commitb8f16535e2385ac826708c2bdca2b0ab5822e4b0 (patch)
tree335d31d030caa7647bee26422f19821d0b5a6f95 /tools/Makefile
parentce5b3306950812db8178087500c805b824e20ebb (diff)
downloadupstream-b8f16535e2385ac826708c2bdca2b0ab5822e4b0.tar.gz
upstream-b8f16535e2385ac826708c2bdca2b0ab5822e4b0.tar.bz2
upstream-b8f16535e2385ac826708c2bdca2b0ab5822e4b0.zip
tools: add b43-tools
Move the b43-tools build from the mac80211 Makefile into an own package in tools and use the newest version of b43-tools. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33668 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 842926ae7d..620da05f00 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -25,6 +25,9 @@ ifneq ($(CONFIG_TARGET_ar71xx),)
tools-y += lzma-old squashfs
endif
tools-y += lzma squashfs4
+ifneq ($(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_kmod-b43legacy),)
+tools-y += b43-tools
+endif
ifneq ($(CONFIG_PACKAGE_firmwarehotplug),)
tools-y += sdcc
@@ -64,6 +67,7 @@ $(curdir)/missing-macros/compile := $(curdir)/automake/install
$(curdir)/e2fsprogs/compile := $(curdir)/automake/install
$(curdir)/libelf/compile := $(curdir)/automake/install
$(curdir)/sdcc/compile := $(curdir)/bison/install
+$(curdir)/b43-tools/compile := $(curdir)/bison/install
ifneq ($(CONFIG_CCACHE),)
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))