aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-12-10 15:20:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-12-10 15:20:44 +0000
commitb7cd143d1c3c7262431c9f4d8c3f7a6dc75b3f02 (patch)
tree8a7577027fcdad6661c4a6c89e1f986e197e25f6 /tools/Makefile
parentb32550f764f5c8502946a57663a6f45d5c2f8e2a (diff)
downloadupstream-b7cd143d1c3c7262431c9f4d8c3f7a6dc75b3f02.tar.gz
upstream-b7cd143d1c3c7262431c9f4d8c3f7a6dc75b3f02.tar.bz2
upstream-b7cd143d1c3c7262431c9f4d8c3f7a6dc75b3f02.zip
make $(STAGING_DIR)/host/share/aclocal a symlink to $(STAGING_DIR_HOST)/share/aclocal
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24422 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 9306601c7a..4a39663cdb 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -61,8 +61,11 @@ define PrepareStaging
endef
# preparatory work
-$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build
+$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
$(call PrepareStaging,$(STAGING_DIR))
+ mkdir -p $(STAGING_DIR)/host/share
+ rm -rf $(STAGING_DIR)/host/share/aclocal
+ ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
mkdir -p $(BUILD_DIR)/stamp
touch $@