aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-01-15 11:43:13 +0000
committerJohn Crispin <blogic@openwrt.org>2012-01-15 11:43:13 +0000
commit1e0b48fafb133310de5e166adaf0c3957e7bee05 (patch)
tree5e1b24560a28f3d1faf6dc571355446688ffcdaa /tools/Makefile
parent8f76568da91dbe989e5365a4a6d3f50847b1c755 (diff)
downloadupstream-1e0b48fafb133310de5e166adaf0c3957e7bee05.tar.gz
upstream-1e0b48fafb133310de5e166adaf0c3957e7bee05.tar.bz2
upstream-1e0b48fafb133310de5e166adaf0c3957e7bee05.zip
tools: clean up Makefiles / make ccache work
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 0c2706d7a8..9f8665ca99 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -21,10 +21,9 @@ tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_powerpc) += upx
tools-$(CONFIG_TARGET_x86) += qemu
ifneq ($(CONFIG_TARGET_ar71xx),)
-tools-y += lzma-old squashfs
+tools-y += lzma-old squashfs
endif
tools-y += lzma squashfs4
-tools-$(CONFIG_CCACHE) += ccache
ifdef CONFIG_GCC_USE_GRAPHITE
ifeq ($(CONFIG_GCC_USE_SYSTEM_PPL_CLOOG),)
@@ -59,6 +58,11 @@ $(curdir)/missing-macros/compile := $(curdir)/automake/install
$(curdir)/e2fsprogs/compile := $(curdir)/automake/install
$(curdir)/libelf/compile := $(curdir)/automake/install
+ifneq ($(CONFIG_CCACHE),)
+$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/install))
+tools-y += ccache
+endif
+
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)