aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-08-10 17:56:41 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-25 13:45:18 +0100
commit6a7cde15000832ce0164dc27d85822b2e2dd9fe6 (patch)
tree87700aea766f6370ef4a89fdf10b0f41a891b59b /toolchain
parent743c4ad6824a17a5ec102ef009684a70801bda62 (diff)
downloadupstream-6a7cde15000832ce0164dc27d85822b2e2dd9fe6.tar.gz
upstream-6a7cde15000832ce0164dc27d85822b2e2dd9fe6.tar.bz2
upstream-6a7cde15000832ce0164dc27d85822b2e2dd9fe6.zip
toolchain: cleanup dependencies
Reorganize dependencies between toolchain targets to save a line. This also puts them in a linear order which is easier to read. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 19b144ee36..60e3507250 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -34,8 +34,8 @@ $(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN)
# builddir dependencies
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
ifdef CONFIG_USE_MUSL
+ $(curdir)/gcc/initial/compile:=$(curdir)/binutils/compile
$(curdir)/kernel-headers/compile:=$(curdir)/gcc/initial/compile
- $(curdir)/$(LIBC)/compile:=$(curdir)/kernel-headers/compile
else
$(curdir)/builddirs += $(LIBC)/headers gcc/minimal
$(curdir)/gcc/minimal/compile:=$(curdir)/binutils/compile
@@ -44,9 +44,8 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(curdir)/gcc/initial/compile:=$(curdir)/$(LIBC)/headers/compile
endif
- $(curdir)/gcc/initial/compile+=$(curdir)/binutils/compile
- $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile
- $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile $(curdir)/kernel-headers/compile
+ $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile $(curdir)/kernel-headers/compile
+ $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
$(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
endif