aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-01-31 12:04:00 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-02-09 02:53:35 +0100
commit4b8b89da506d1272ccbf944b1ece6c8ddaeff2ed (patch)
treed58ae10f2e03fb166d59816686691e55e588d962 /toolchain
parentdd39f760b75070dfc6589fa9e63e3a1525bd7e2c (diff)
downloadupstream-4b8b89da506d1272ccbf944b1ece6c8ddaeff2ed.tar.gz
upstream-4b8b89da506d1272ccbf944b1ece6c8ddaeff2ed.tar.bz2
upstream-4b8b89da506d1272ccbf944b1ece6c8ddaeff2ed.zip
toolchain/gcc: use explicit configure args
Spell out what we want to enable or disable. This prevents host libs to leak in, so everyone get the same feature set. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk2
-rw-r--r--toolchain/gcc/final/Makefile1
2 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 7eae855eea..5f314c7fc0 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -106,6 +106,8 @@ GCC_CONFIGURE:= \
--with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
$(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
$(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--with-abi=elfv2)) \
+ --with-system-zlib=$(STAGING_DIR_HOST) \
+ --without-zstd \
--with-gmp=$(STAGING_DIR_HOST) \
--with-mpfr=$(STAGING_DIR_HOST) \
--with-mpc=$(STAGING_DIR_HOST) \
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 049ddf61f0..78a5576bff 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -8,6 +8,7 @@ GCC_CONFIGURE += \
--enable-shared \
--enable-threads \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
+ --enable-plugins \
--enable-lto \
--with-libelf=$(STAGING_DIR_HOST)