aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-12-02 20:33:14 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-01-09 21:33:19 +0100
commitd10e6591d1523738852dd0ab625df1f9ea7fc63c (patch)
tree95f5fdcf5cd1f79ffd7939064a49f7cdd2c56fa2 /toolchain
parent9590e1155d7a9dcfc30ba0a95ccea43698bab8cf (diff)
downloadupstream-d10e6591d1523738852dd0ab625df1f9ea7fc63c.tar.gz
upstream-d10e6591d1523738852dd0ab625df1f9ea7fc63c.tar.bz2
upstream-d10e6591d1523738852dd0ab625df1f9ea7fc63c.zip
toolchain/gdb: use STAGING_DIR_HOST instead of hardcoding default
Use STAGING_DIR_HOST to reference staging host directory instead of hardcoding it to default path. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gdb/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 4587c591f4..70a4fa5902 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -30,10 +30,10 @@ HOST_CONFIGURE_ARGS = \
--build=$(GNU_HOST_NAME) \
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
- --with-gmp=$(TOPDIR)/staging_dir/host \
- --with-mpfr=$(TOPDIR)/staging_dir/host \
- --with-mpc=$(TOPDIR)/staging_dir/host \
- --with-expat=$(TOPDIR)/staging_dir/host \
+ --with-gmp=$(STAGING_DIR_HOST) \
+ --with-mpfr=$(STAGING_DIR_HOST) \
+ --with-mpc=$(STAGING_DIR_HOST) \
+ --with-expat=$(STAGING_DIR_HOST) \
--disable-werror \
--without-uiout \
--enable-tui --disable-gdbtk --without-x \