aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-09-09 21:43:18 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-25 13:45:18 +0100
commit743c4ad6824a17a5ec102ef009684a70801bda62 (patch)
tree1b3bd961cdf36979578bcca5c792b4da3a8f0818 /toolchain
parent638ebd306794397975bdf8035f6b23b61bc5c1c8 (diff)
downloadupstream-743c4ad6824a17a5ec102ef009684a70801bda62.tar.gz
upstream-743c4ad6824a17a5ec102ef009684a70801bda62.tar.bz2
upstream-743c4ad6824a17a5ec102ef009684a70801bda62.zip
toolchain: fix stampfile dependency
Use the gcc/final/install target stampfile as the prerequisite for the toolchain/compile target stampfile. The previous filename was also incorrect, the stampfile name format was changed (see reference) but was never updated here. The issue was never noticed because the usage of timestamp.pl was broken (fixed in previous commit) causing the extra prereq files passed to 'call stampfile' to never get checked at all. Fixes: 5149ed151 ("gcc: split up the build process into three distinct stages") Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 5dccf8f829..19b144ee36 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -85,12 +85,12 @@ $(curdir)/ := .config prereq
$(curdir)//compile = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk $(tools/stamp-compile)
ifndef DUMP_TARGET_DB
-$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+$(TOOLCHAIN_DIR)/stamp/.gcc_final_installed:
endif
$(curdir)/install: $(curdir)/compile
-$(eval $(call stampfile,$(curdir),toolchain,compile,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
+$(eval $(call stampfile,$(curdir),toolchain,compile,$(TOOLCHAIN_DIR)/stamp/.gcc_final_installed,,$(TOOLCHAIN_DIR)))
$(eval $(call stampfile,$(curdir),toolchain,check,$(TMP_DIR)/.build))
$(eval $(call subdir,$(curdir)))