aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-05-09 23:47:01 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-12 12:11:20 +0200
commit8d2ab0fac666b9d2f39f517594b414466ff85818 (patch)
tree0366f7b02ada65deae003039992198d90a676838 /toolchain
parent7890dd75adc6bf202e8b9841f361dde2f7b5e6fb (diff)
downloadupstream-8d2ab0fac666b9d2f39f517594b414466ff85818.tar.gz
upstream-8d2ab0fac666b9d2f39f517594b414466ff85818.tar.bz2
upstream-8d2ab0fac666b9d2f39f517594b414466ff85818.zip
toolchain: gcc: update to 12.3.0
Release notes: https://gcc.gnu.org/gcc-12/changes.html Refresh patches: - 230-musl_libssp.patch - 910-mbsd_multi.patch - 920-specs_nonfatal_getenv.patch - 970-macos_arm64-building-fix.patch Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches-12.x/230-musl_libssp.patch2
-rw-r--r--toolchain/gcc/patches-12.x/910-mbsd_multi.patch2
-rw-r--r--toolchain/gcc/patches-12.x/920-specs_nonfatal_getenv.patch2
-rw-r--r--toolchain/gcc/patches-12.x/970-macos_arm64-building-fix.patch2
6 files changed, 7 insertions, 7 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 1c1b0a04a1..7126a0c883 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -10,4 +10,4 @@ config GCC_VERSION
string
default "11.3.0" if GCC_VERSION_11
default "13.1.0" if GCC_VERSION_13
- default "12.2.0"
+ default "12.3.0"
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index ebe4b484cf..677fb25381 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -33,8 +33,8 @@ ifeq ($(PKG_VERSION),11.3.0)
PKG_HASH:=b47cf2818691f5b1e21df2bb38c795fac2cfbd640ede2d0a5e1c89e338a3ac39
endif
-ifeq ($(PKG_VERSION),12.2.0)
- PKG_HASH:=e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
+ifeq ($(PKG_VERSION),12.3.0)
+ PKG_HASH:=949a5d4f99e786421a93b532b22ffab5578de7321369975b91aec97adfda8c3b
endif
ifeq ($(PKG_VERSION),13.1.0)
diff --git a/toolchain/gcc/patches-12.x/230-musl_libssp.patch b/toolchain/gcc/patches-12.x/230-musl_libssp.patch
index 3ce5e49587..a909d63875 100644
--- a/toolchain/gcc/patches-12.x/230-musl_libssp.patch
+++ b/toolchain/gcc/patches-12.x/230-musl_libssp.patch
@@ -1,6 +1,6 @@
--- a/gcc/gcc.cc
+++ b/gcc/gcc.cc
-@@ -985,7 +985,9 @@ proper position among the other output f
+@@ -987,7 +987,9 @@ proper position among the other output f
#endif
#ifndef LINK_SSP_SPEC
diff --git a/toolchain/gcc/patches-12.x/910-mbsd_multi.patch b/toolchain/gcc/patches-12.x/910-mbsd_multi.patch
index 4033c5b23b..0f75d0ce0e 100644
--- a/toolchain/gcc/patches-12.x/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches-12.x/910-mbsd_multi.patch
@@ -134,7 +134,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
@opindex Wno-stack-protector
--- a/gcc/opts.cc
+++ b/gcc/opts.cc
-@@ -2692,6 +2692,9 @@ common_handle_option (struct gcc_options
+@@ -2699,6 +2699,9 @@ common_handle_option (struct gcc_options
add_comma_separated_to_vector (&opts->x_flag_ignored_attributes, arg);
break;
diff --git a/toolchain/gcc/patches-12.x/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches-12.x/920-specs_nonfatal_getenv.patch
index 0f7d40b244..59bd350044 100644
--- a/toolchain/gcc/patches-12.x/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches-12.x/920-specs_nonfatal_getenv.patch
@@ -7,7 +7,7 @@ Date: Sat Apr 21 03:02:39 2012 +0000
--- a/gcc/gcc.cc
+++ b/gcc/gcc.cc
-@@ -10213,8 +10213,10 @@ getenv_spec_function (int argc, const ch
+@@ -10186,8 +10186,10 @@ getenv_spec_function (int argc, const ch
}
if (!value)
diff --git a/toolchain/gcc/patches-12.x/970-macos_arm64-building-fix.patch b/toolchain/gcc/patches-12.x/970-macos_arm64-building-fix.patch
index 86fa68e1b1..89730449f5 100644
--- a/toolchain/gcc/patches-12.x/970-macos_arm64-building-fix.patch
+++ b/toolchain/gcc/patches-12.x/970-macos_arm64-building-fix.patch
@@ -17,7 +17,7 @@ Date: Mon Aug 16 13:16:21 2021 +0100
--- a/gcc/config/aarch64/aarch64.h
+++ b/gcc/config/aarch64/aarch64.h
-@@ -1290,7 +1290,7 @@ extern const char *aarch64_rewrite_mcpu
+@@ -1293,7 +1293,7 @@ extern const char *aarch64_rewrite_mcpu
#define MCPU_TO_MARCH_SPEC_FUNCTIONS \
{ "rewrite_mcpu", aarch64_rewrite_mcpu },