aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-01-18 07:51:45 +0100
committerPetr Štetiar <ynezz@true.cz>2023-01-18 07:51:56 +0100
commitc1a26341ab979a8029aa2ffed73fa04b95071119 (patch)
tree5fc937206027d8569866be7ee8321c9e168ccd4b /toolchain
parent807483d3365f3dd011e3790695512d443cf2f267 (diff)
downloadupstream-c1a26341ab979a8029aa2ffed73fa04b95071119.tar.gz
upstream-c1a26341ab979a8029aa2ffed73fa04b95071119.tar.bz2
upstream-c1a26341ab979a8029aa2ffed73fa04b95071119.zip
Revert "toolchaini/gcc: fix libstdc++ dual abi model"
This reverts commit c0b4303d2e2f4a9e1d4684fd584e6b6548666f0f as it was reported, that it breaks all packages depending on libstdcpp due to changed ABI. References: https://github.com/openwrt/packages/issues/20340 Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index fb280e942f..bef4fa37f8 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -115,7 +115,7 @@ GCC_CONFIGURE:= \
--disable-decimal-float \
--with-diagnostics-color=auto-if-env \
--enable-__cxa_atexit \
- --enable-libstdcxx-dual-abi \
+ --disable-libstdcxx-dual-abi \
--with-default-libstdcxx-abi=new
ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt