aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorIvan Maslov <avenger_msoft@mail.ru>2022-01-29 23:11:30 +0300
committerPetr Štetiar <ynezz@true.cz>2023-01-16 08:45:38 +0100
commitc0b4303d2e2f4a9e1d4684fd584e6b6548666f0f (patch)
treede5998c1525906c0fa5d43689680a4453bf22ea0 /toolchain
parentaa5023b9cd0f31921561005c30bde49cf0834902 (diff)
downloadupstream-c0b4303d2e2f4a9e1d4684fd584e6b6548666f0f.tar.gz
upstream-c0b4303d2e2f4a9e1d4684fd584e6b6548666f0f.tar.bz2
upstream-c0b4303d2e2f4a9e1d4684fd584e6b6548666f0f.zip
toolchaini/gcc: fix libstdc++ dual abi model
libstdcxx-dual-abi needs to be enabled to actually support C++11 ABI. Enable the config flag to also permit support of .NET 6 development on OpenWrt. Signed-off-by: Ivan Maslov <avenger_msoft@mail.ru> [ reword commit description and title ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit 3c06a344e9c7c03c49c9153342e68a5390651323)
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index bef4fa37f8..fb280e942f 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -115,7 +115,7 @@ GCC_CONFIGURE:= \
--disable-decimal-float \
--with-diagnostics-color=auto-if-env \
--enable-__cxa_atexit \
- --disable-libstdcxx-dual-abi \
+ --enable-libstdcxx-dual-abi \
--with-default-libstdcxx-abi=new
ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
GCC_CONFIGURE += --with-mips-plt