aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2023-10-07 12:34:24 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-10-07 13:57:56 +0200
commit4ad0f92b813c48d9ed9ca120909a28c27ef20ef3 (patch)
tree457839d5275882a9de28da48750c38db8a3244e8 /toolchain
parentf6fa7b5d43879a48fb6c49db9bb6d560be0659ac (diff)
downloadupstream-4ad0f92b813c48d9ed9ca120909a28c27ef20ef3.tar.gz
upstream-4ad0f92b813c48d9ed9ca120909a28c27ef20ef3.tar.bz2
upstream-4ad0f92b813c48d9ed9ca120909a28c27ef20ef3.zip
toolchain: Update glibc 2.34 to recent HEAD
This adds the following changes: 42eb735a5d Use LFS and 64 bit time for installed programs (BZ #15333) d910ba48f4 nis: Build libnsl with 64 bit time_t 01c0a0405c nscd: Use 64 bit time_t on libc nscd routines (BZ# 29402) e14a91e59d time: Use 64 bit time on tzfile d0e2ac0c59 elf/tst-tlsopt-powerpc fails when compiled with -mcpu=power10 (BZ# 29776) 71d4fe94a1 time: Set daylight to 1 for matching DST/offset change (bug 29951) bbe4bbb6e8 elf: Drop elf/tls-macros.h in favor of __thread and tls_model attributes [BZ #28152] [BZ #28205] d36f457870 intl: Avoid -Wuse-after-free [BZ #26779] 92d5c52aaa resolv: Avoid GCC 12 false positive warning [BZ #28439]. 26c7c6bac9 Fix stdlib/tst-setcontext.c for GCC 12 -Warray-compare 6ff61a5145 Fix stdio-common tests for GCC 12 -Waddress 803c959745 Fix build of nptl/tst-thread_local1.cc with GCC 12 88b3228d9f Avoid -Wuse-after-free in tests [BZ #26779]. dd0c72fb46 Regenerate ulps on x86_64 with GCC 12 80b24b8654 math: Properly cast X_TLOSS to float [BZ #28713] c5c666f349 s_sincosf.h: Change pio4 type to float [BZ #28713] 6484ae5b8c malloc: Fix -Wuse-after-free warning in tst-mallocalign1 [BZ #26779] c5c792092b cdefs: Limit definition of fortification macros 0b962177ee Use 64-bit time_t interfaces in strftime and strptime (bug 30053) 48059f2b21 Fix NEWS bug entry for 0b962177ee3b45cf775176eb454fcf6aa1b0f6e3 11ad405fd4 elf: Fix 64 time_t support for installed statically binaries 2d7550e6cf elf: Smoke-test ldconfig -p against system /etc/ld.so.cache 16c6a89c17 stdlib: Undo post review change to 16adc58e73f3 [BZ #27749] 89c017de2f x86: Check minimum/maximum of non_temporal_threshold [BZ #29953] 6a0d56b009 gshadow: Matching sgetsgent, sgetsgent_r ERANGE handling (bug 30151) 71eb9cc1ff x86_64: Fix asm constraints in feraiseexcept (bug 30305) 567f7413fb posix: Fix system blocks SIGCHLD erroneously [BZ #30163] 8e1a8e04b1 gmon: Fix allocated buffer overflow (bug 29444) 4dd89b2a8f gmon: improve mcount overflow handling [BZ# 27576] f1b15d2005 gmon: fix memory corruption issues [BZ# 30101] 0ea8174d62 gmon: Revert addition of tunables to preserve GLIBC_PRIVATE ABI 1cd6626a89 __check_pf: Add a cancellation cleanup handler [BZ #20975] cad3adf4dd Document BZ #20975 fix 23ee92deea debug: Mark libSegFault.so as NODELETE c8c0aac68f x86: Increase `non_temporal_threshold` to roughly `sizeof_L3 / 4` 521afc9637 x86: Fix slight bug in `shared_per_thread` cache size calculation. a07ab67a88 x86: Use `3/4*sizeof(per-thread-L3)` as low bound for NT threshold. 7a6b1f06e7 x86: Fix incorrect scope of setting `shared_per_thread` [BZ# 30745] 228cdb00a0 Simplify allocations and fix merge and continue actions [BZ #28931] 51948fdf0f nss: Sort tests and tests-container and put one test per line 01671608a3 gethosts: Remove unused argument _type b195fd86c6 gaih_inet: Simplify canon name resolution f7efb43738 getaddrinfo: Fix leak with AI_ALL [BZ #28852] e05e5889b8 gaih_inet: Simplify service resolution 922f2614d6 gaih_inet: make numeric lookup a separate routine 3b5a3e5009 gaih_inet: Split simple gethostbyname into its own function 5914a1d55b gaih_inet: Split nscd lookup code into its own function. ec71cb9611 gaih_inet: separate nss lookup loop into its own function 4d59769087 gaih_inet: make gethosts into a function 6e3fed9d20 gaih_inet: split loopback lookup into its own function 92478a808f gaih_inet: Split result generation into its own function cc4544ef80 gethosts: Return EAI_MEMORY on allocation failure e09ee267c0 getaddrinfo: Fix use after free in getcanonname (CVE-2023-4806) 8006457ab7 Fix leak in getaddrinfo introduced by the fix for CVE-2023-4806 [BZ #30843] c3b99f8328 Document CVE-2023-4806 and CVE-2023-5156 in NEWS dcc367f148 tunables: Terminate if end of input is reached (CVE-2023-4911) Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/glibc/common.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 06fd531b3d..65b95ceb3b 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -12,8 +12,8 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a4217408a3d6050a7f42ac23adb6ac7218dca85f
-PKG_MIRROR_HASH:=3c8b0a515587a5d92d242f63355fed4e92a4fbcabdea213c62282e7d364ec485
+PKG_SOURCE_VERSION:=dcc367f148bc92e7f3778a125f7a416b093964d9
+PKG_MIRROR_HASH:=759a6de0ef1041aba5db1dacb298e8d77b4cb1a687c632e85307e5bd4484e73f
PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
PKG_CPE_ID:=cpe:/a:gnu:glibc