aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2021-12-28 21:25:16 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-07 22:30:40 +0100
commite708bf76d5a3d936228ae414f999cce36fd66d98 (patch)
treeb23901594765c3defb5301f5517f6fef825e070a /toolchain
parent4d1f13356196103769e610920a9681b731b089d3 (diff)
downloadupstream-e708bf76d5a3d936228ae414f999cce36fd66d98.tar.gz
upstream-e708bf76d5a3d936228ae414f999cce36fd66d98.tar.bz2
upstream-e708bf76d5a3d936228ae414f999cce36fd66d98.zip
toolchain: glibc: Update to version 2.34
glibc version 2.34 does not provide versioned shared libraries any more, it only provides shared libraries using the ABI version. Do not try to copy them any more. The functions from libpthread and librt were integrated into the main binary, the libpthread.so and librt.so are only used for backwards compatibility any more. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/glibc/common.mk8
-rw-r--r--toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch6
-rw-r--r--toolchain/glibc/patches/200-add-dl-search-paths.patch2
3 files changed, 8 insertions, 8 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index b5f2a513b1..aa8458360f 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=glibc
-PKG_VERSION:=2.33
-PKG_RELEASE:=2
+PKG_VERSION:=2.34
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=9b01145592fdbffbcbb949d680c152ed2bf2375d
-PKG_MIRROR_HASH:=a1bf0858828ee0f68c7847ce9504bb10ce943d0c8fe801d7ba307add2a238c5b
+PKG_SOURCE_VERSION:=d5ba02f67dd62a63e29c29eebd6c543722aa6b5b
+PKG_MIRROR_HASH:=19e49929c7ea3480a0d1213b6763a23a5ed8129a34fe201a985498927c583ce1
PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
diff --git a/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch b/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch
index 10d9f65d18..cb2ae0550b 100644
--- a/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch
+++ b/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch
@@ -469,7 +469,7 @@ provides them.
* Encode Binary Data:: Encoding and Decoding of Binary Data.
* Argz and Envz Vectors:: Null-separated string vectors.
@end menu
-@@ -2426,73 +2426,73 @@ functionality under a different name, su
+@@ -2423,73 +2423,73 @@ functionality under a different name, su
systems it may be in @file{strings.h} instead.
@end deftypefun
@@ -596,7 +596,7 @@ provides them.
/* The enhanced internationalization capabilities according to XPG4.2
are present. */
#define _XOPEN_ENH_I18N 1
-@@ -1129,17 +1132,25 @@ ssize_t copy_file_range (int __infd, __o
+@@ -1146,17 +1149,25 @@ ssize_t copy_file_range (int __infd, __o
extern int fdatasync (int __fildes);
#endif /* Use POSIX199309 */
@@ -627,7 +627,7 @@ provides them.
range [FROM - N + 1, FROM - 1]. If N is odd the first byte in FROM
--- a/stdlib/stdlib.h
+++ b/stdlib/stdlib.h
-@@ -962,6 +962,12 @@ extern int getsubopt (char **__restrict
+@@ -968,6 +968,12 @@ extern int getsubopt (char **__restrict
#endif
diff --git a/toolchain/glibc/patches/200-add-dl-search-paths.patch b/toolchain/glibc/patches/200-add-dl-search-paths.patch
index 18d751dd1a..08e901d2e6 100644
--- a/toolchain/glibc/patches/200-add-dl-search-paths.patch
+++ b/toolchain/glibc/patches/200-add-dl-search-paths.patch
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig
+++ b/Makeconfig
-@@ -601,6 +601,9 @@ else
+@@ -610,6 +610,9 @@ else
default-rpath = $(libdir)
endif