aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-21 22:56:26 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-21 22:56:26 +0000
commitcb8f9f23ed3d1f9763c8880758b862d14df46f0b (patch)
tree91975a21a886e2236de7125ce61a66f1ef664cd0 /toolchain
parent609293d3cb2410018c4078bcbd267bf7581f13bf (diff)
downloadupstream-cb8f9f23ed3d1f9763c8880758b862d14df46f0b.tar.gz
upstream-cb8f9f23ed3d1f9763c8880758b862d14df46f0b.tar.bz2
upstream-cb8f9f23ed3d1f9763c8880758b862d14df46f0b.zip
[toolchain] fix uClibc fpu/soft-float selection
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14141 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index c5771bd5ce..245383021f 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -124,7 +124,8 @@ define Build/Prepare
$(call Build/Prepare/V_0_9_28)
endif
$(SED) 's,^KERNEL_HEADERS=.*,KERNEL_HEADERS=\"$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include\",g' \
- -e 's,.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n\nUCLIBC_HAS_FLOATS=y\nUCLIBC_HAS_SOFT_FLOAT=y,y),g' \
+ -e 's,^.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n,y),g' \
+ -e 's,^.*UCLIBC_HAS_SOFT_FLOAT.*,UCLIBC_HAS_SOFT_FLOAT=$(if $(CONFIG_SOFT_FLOAT),y,n),g' \
-e 's,^.*UCLIBC_HAS_LFS.*,UCLIBC_HAS_LFS=$(if $(CONFIG_LARGEFILE),y,n),g' \
-e 's,^.*CONFIG_ARM_EABI.*,CONFIG_ARM_EABI=$(if $(CONFIG_EABI_SUPPORT),y,n),g' \
-e 's,^.*CONFIG_ARM_OABI.*,CONFIG_ARM_OABI=$(if $(CONFIG_EABI_SUPPORT),n,y),g' \