aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2007-04-04 14:33:52 +0000
committerHamish Guthrie <hcg@openwrt.org>2007-04-04 14:33:52 +0000
commit8eee721db6011ac50373466a0ed0c0528b99515c (patch)
treee8e9381e46fc6e4c50b98f819446338e6bf3e4a6 /toolchain
parentf5421830672ff4ccb60b0e4ad7f658bfff25c7f3 (diff)
downloadupstream-8eee721db6011ac50373466a0ed0c0528b99515c.tar.gz
upstream-8eee721db6011ac50373466a0ed0c0528b99515c.tar.bz2
upstream-8eee721db6011ac50373466a0ed0c0528b99515c.zip
Cleanups on romboot and u-boot.
Conditionally apply ldd and ldconfig support on at91 platform git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6862 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 2f95b0c44f..93a994ebb6 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -93,12 +93,14 @@ define Build/Install
RUNTIME_PREFIX=/ \
install_dev
echo $(PKG_VERSION) > $(STAGING_DIR)/uclibc_version
+ifneq ($(CONFIG_LINUX_2_6_AT91),y)
echo $(PKG_VERSION)$(PKG_EXTRAVERSION) > $(STAGING_DIR)/uclibc_extra_version
$(MAKE) -C $(PKG_BUILD_DIR) \
PREFIX=$(STAGING_DIR)/ \
DEVEL_PREFIX=/ \
RUNTIME_PREFIX=/ \
utils
+endif
endef
define Build/Clean