aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-01 05:41:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-01 05:41:02 +0000
commitcdabc8deda9718ccb330e48ec031aeaf6f6fdce5 (patch)
tree923204345c7d156c364fcda83f38715815e4f863 /toolchain
parent9cb0783a7f6612fa80d6a927654450fe9b951385 (diff)
downloadupstream-cdabc8deda9718ccb330e48ec031aeaf6f6fdce5.tar.gz
upstream-cdabc8deda9718ccb330e48ec031aeaf6f6fdce5.tar.bz2
upstream-cdabc8deda9718ccb330e48ec031aeaf6f6fdce5.zip
uClibc: set the toolchain info at install time instead of prepare time, fixes staging dir rebuilds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25803 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 0ce9554e78..642f7fba4c 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -62,7 +62,6 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
define Host/Prepare
- $(call Host/SetToolchainInfo)
$(call Host/Prepare/Default)
$(if $(strip $(QUILT)), \
cd $(HOST_BUILD_DIR); \
@@ -132,6 +131,7 @@ define Host/Compile
endef
define Host/Install
+ $(call Host/SetToolchainInfo)
$(UCLIBC_MAKE) PREFIX= utils
$(INSTALL_DIR) $(TOOLCHAIN_DIR)/bin
$(INSTALL_BIN) \