aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-07-23 16:53:51 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-04 13:35:53 +0200
commit930c141b69c7dd19e474586290573a19f69aa5a2 (patch)
treec9e1ce993aaea829347e16251a20d47a7a7ea964 /toolchain
parentcc7560eb22d2c491a0a995135780f3e8aa3cfa6f (diff)
downloadupstream-930c141b69c7dd19e474586290573a19f69aa5a2.tar.gz
upstream-930c141b69c7dd19e474586290573a19f69aa5a2.tar.bz2
upstream-930c141b69c7dd19e474586290573a19f69aa5a2.zip
toolchain: fix gcc depends on kernel headers
GCC needs the kernel headers to compile. Some GCC file includes asm/unistd.h which is provided by the kernel headers. Normally the kernel headers build is very fast and ready before the gcc uses it, but if it clones the kernel from a slow git repository it takes longer and then it could be that the gcc already wants to use the kernel headers before they are available. This patch fixes this problem by adding the missing dependency. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com> (cherry picked from commit b20156ba704ed8e03d030b2f294d8d19bebd2f71)
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 0336b2f72c..23a5529eed 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -49,7 +49,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(curdir)/gcc/initial/compile+=$(curdir)/binutils/compile
$(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile
- $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
+ $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile $(curdir)/kernel-headers/compile
$(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
endif