aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-06-23 11:46:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-06-23 11:46:24 +0000
commit28fbd7470d1c35edf1de93a0ac26027cf47c724c (patch)
treead54f594307f6173691fd3e2eb1fbf3bf366b54e /toolchain
parenta56dab661a115e6cc9f4361d5ff831d998cb9f00 (diff)
downloadupstream-28fbd7470d1c35edf1de93a0ac26027cf47c724c.tar.gz
upstream-28fbd7470d1c35edf1de93a0ac26027cf47c724c.tar.bz2
upstream-28fbd7470d1c35edf1de93a0ac26027cf47c724c.zip
add gfortran compiler support (#9600, patch from Xiangfu Liu via Qi hardware)
SVN-Revision: 27262
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in8
-rw-r--r--toolchain/gcc/common.mk2
2 files changed, 9 insertions, 1 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index e6434d0f7d..6b45da55bd 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -89,3 +89,11 @@ config INSTALL_LIBGCJ
default n
help
Build/install java compiler and GNU classpath ?
+
+
+config INSTALL_GFORTRAN
+ bool
+ prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
+ default n
+ help
+ Build/install GNU fortran compiler ?
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index e047ace653..1ef14a87ed 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -86,7 +86,7 @@ HOST_STAMP_CONFIGURED:=$(GCC_BUILD_DIR)/.configured
HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.gcc_$(GCC_VARIANT)_installed
SEP:=,
-TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
+TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)"
export libgcc_cv_fixed_point=no
ifdef CONFIG_USE_UCLIBC