aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-24 10:07:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-24 10:07:07 +0000
commit8312ae2c539afc65d6be4ee9ea141db42cd0d042 (patch)
treebd4c92c473b7db976f399c1ca158f207bf59cea7 /toolchain
parent1d42b9b8617e25cd3efdc73ad6018982bd8d90a8 (diff)
downloadupstream-8312ae2c539afc65d6be4ee9ea141db42cd0d042.tar.gz
upstream-8312ae2c539afc65d6be4ee9ea141db42cd0d042.tar.bz2
upstream-8312ae2c539afc65d6be4ee9ea141db42cd0d042.zip
uClibc: remove avr32 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44961 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/common.mk1
-rw-r--r--toolchain/uClibc/config-0.9.33.2/avr3212
-rw-r--r--toolchain/uClibc/patches-0.9.33.2/140-avr32_atomic_fix.patch10
3 files changed, 0 insertions, 23 deletions
diff --git a/toolchain/uClibc/common.mk b/toolchain/uClibc/common.mk
index 435e4c2511..610532c839 100644
--- a/toolchain/uClibc/common.mk
+++ b/toolchain/uClibc/common.mk
@@ -26,7 +26,6 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/i.86/i386/' \
-e 's/sparc.*/sparc/' \
-e 's/arm.*/arm/g' \
- -e 's/avr32.*/avr32/g' \
-e 's/m68k.*/m68k/' \
-e 's/ppc/powerpc/g' \
-e 's/v850.*/v850/g' \
diff --git a/toolchain/uClibc/config-0.9.33.2/avr32 b/toolchain/uClibc/config-0.9.33.2/avr32
deleted file mode 100644
index 729fbc9a33..0000000000
--- a/toolchain/uClibc/config-0.9.33.2/avr32
+++ /dev/null
@@ -1,12 +0,0 @@
-ARCH_BIG_ENDIAN=y
-CONFIG_AVR32_AP7=y
-FORCE_SHAREABLE_TEXT_SEGMENTS=y
-LINKRELAX=y
-LINUXTHREADS_OLD=y
-TARGET_ARCH="avr32"
-TARGET_avr32=y
-UCLIBC_HAS_FPU=y
-# UCLIBC_HAS_SCANF_GLIBC_A_FLAG is not set
-# UCLIBC_HAS_STRING_ARCH_OPT is not set
-# UCLIBC_HAS_THREADS_NATIVE is not set
-UNIX98PTY_ONLY=y
diff --git a/toolchain/uClibc/patches-0.9.33.2/140-avr32_atomic_fix.patch b/toolchain/uClibc/patches-0.9.33.2/140-avr32_atomic_fix.patch
deleted file mode 100644
index 5e5460a3dc..0000000000
--- a/toolchain/uClibc/patches-0.9.33.2/140-avr32_atomic_fix.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/libc/sysdeps/linux/avr32/bits/atomic.h
-+++ b/libc/sysdeps/linux/avr32/bits/atomic.h
-@@ -28,6 +28,7 @@ typedef uintmax_t uatomic_max_t;
-
- #define __arch_compare_and_exchange_val_32_acq(mem, newval, oldval) \
- ({ \
-+ __uint32_t __result; \
- __typeof__(*(mem)) __prev; \
- __asm__ __volatile__( \
- "/* __arch_compare_and_exchange_val_32_acq */\n" \