aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 08:53:27 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 08:53:27 +0000
commit3ea83f06882978c5406dfbe1b862e94834f943aa (patch)
tree0ba5b39f15d81e3949519bee8842a2b2d0a4d221 /toolchain
parent706ffd80683910dfddf2e0ffd4c3e41dca0d695f (diff)
downloadupstream-3ea83f06882978c5406dfbe1b862e94834f943aa.tar.gz
upstream-3ea83f06882978c5406dfbe1b862e94834f943aa.tar.bz2
upstream-3ea83f06882978c5406dfbe1b862e94834f943aa.zip
CC: toolchain: use latest glibc 2.21 revision
Fixes "CVE-2015-7547 --- glibc getaddrinfo() stack-based buffer overflow" Signed-off-by: Michael Marley <michael@michaelmarley.com> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48864 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/glibc/Config.version6
-rw-r--r--toolchain/glibc/common.mk12
-rw-r--r--toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch2
3 files changed, 12 insertions, 8 deletions
diff --git a/toolchain/glibc/Config.version b/toolchain/glibc/Config.version
index 2ac01d7d73..4ceed09adf 100644
--- a/toolchain/glibc/Config.version
+++ b/toolchain/glibc/Config.version
@@ -12,12 +12,6 @@ config EGLIBC_VERSION_2_19
config GLIBC_VERSION_2_21
bool
-config GLIBC_REVISION
- string
- default "25243" if EGLIBC_VERSION_2_19
- default "4e42b5b8f8" if GLIBC_VERSION_2_21
- default ""
-
endif
menu "eglibc configuration"
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 7487ca2782..3d680bbcf6 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -6,9 +6,19 @@
#
include $(TOPDIR)/rules.mk
+
+MD5SUM_2.19 = 42dad4edd3bcb38006d13b5640b00b38
+REVISION_2.19 = 25243
+
+MD5SUM_2.21 = 76050a65c444d58b5c4aa0d6034736ed
+REVISION_2.21 = 16d0a0c
+
+
PKG_NAME:=glibc
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
+
+PKG_REVISION:=$(REVISION_$(PKG_VERSION))
+PKG_MIRROR_MD5SUM:=$(MD5SUM_$(PKG_VERSION))
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
diff --git a/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch b/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch
index a6200f783b..070f938fe3 100644
--- a/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch
+++ b/toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig
+++ b/Makeconfig
-@@ -501,6 +501,9 @@ else
+@@ -499,6 +499,9 @@ else
default-rpath = $(libdir)
endif