aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-01-12 10:15:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-01-12 10:15:20 +0000
commitfab0eb7e21e6d2d71687e0305db000753245bbb7 (patch)
tree5095b476fa94fa4e8141f234e907b12c24aa62de /toolchain
parentbe4852ef3f654898866d2c47f98d3c03ab5fde95 (diff)
downloadupstream-fab0eb7e21e6d2d71687e0305db000753245bbb7.tar.gz
upstream-fab0eb7e21e6d2d71687e0305db000753245bbb7.tar.bz2
upstream-fab0eb7e21e6d2d71687e0305db000753245bbb7.zip
gcc: always explicitly link against libstdc++, fixes build errors on some hosts that refuse to link it in implicitly (should fix #10587)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29721 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 75ad8af6ff..8b74533350 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -107,7 +107,7 @@ GCC_CONFIGURE:= \
--disable-multilib \
--disable-nls \
$(GRAPHITE_CONFIGURE) \
- $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
+ --with-host-libstdcxx=-lstdc++ \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \