aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-07-14 20:28:53 +0000
committerLuka Perkov <luka@openwrt.org>2014-07-14 20:28:53 +0000
commitba1d7fecf8b29b7c91fb3c029924e6cf43382c44 (patch)
treef150dbfabf19cc500973d547c7a8b0b1d3a3fa6a /toolchain
parent8c511764ea00a3c0753909168353ee2367d1e224 (diff)
downloadupstream-ba1d7fecf8b29b7c91fb3c029924e6cf43382c44.tar.gz
upstream-ba1d7fecf8b29b7c91fb3c029924e6cf43382c44.tar.bz2
upstream-ba1d7fecf8b29b7c91fb3c029924e6cf43382c44.zip
toolchain/gcc: pass proper flags for arm hard float build
This fixes eglibc build failure. More information about the bug can be found on the link below. https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61796 Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41657 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 5dfbc488cd..e8ca778e6e 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -162,6 +162,13 @@ ifneq ($(GCC_ARCH),)
GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
endif
+ifneq ($(CONFIG_SOFT_FLOAT),y)
+ ifeq ($(CONFIG_arm),y)
+ GCC_CONFIGURE+= \
+ --with-float=hard
+ endif
+endif
+
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) \