aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-19 05:28:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-19 05:28:29 +0000
commit2a0552ccb0b88576ea921f98b0a7245a5f26b90f (patch)
tree4edc578ec52cd1f55997f5ba21764675f3a0477f /toolchain
parent863546509a6cc23afa60dc734f2649953bf259b1 (diff)
downloadupstream-2a0552ccb0b88576ea921f98b0a7245a5f26b90f.tar.gz
upstream-2a0552ccb0b88576ea921f98b0a7245a5f26b90f.tar.bz2
upstream-2a0552ccb0b88576ea921f98b0a7245a5f26b90f.zip
gcc: prevent the libgcc configure script from enabling support for the fixed point math extension, as it can bloat up libgcc size to 1.4M on mips
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18066 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index fdcee3f217..4aec5714bf 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -69,6 +69,8 @@ HOST_BUILD_DIR2:=$(HOST_BUILD_DIR)-final
SEP:=,
TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
+export libgcc_cv_fixed_point=no
+
GCC_CONFIGURE:= \
SHELL="$(BASH)" \
$(HOST_BUILD_DIR)/configure \