aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-24 01:34:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-24 01:34:51 +0000
commit5bd40b0870c70a8c11d1f4945c325c14343e53d7 (patch)
treef24565f1d7bb36b363e946851a98cef5ead379e0 /toolchain/uClibc/Makefile
parent9a3368ebca2057f5bfa73f6f3e97bd54b9b0a07b (diff)
downloadupstream-5bd40b0870c70a8c11d1f4945c325c14343e53d7.tar.gz
upstream-5bd40b0870c70a8c11d1f4945c325c14343e53d7.tar.bz2
upstream-5bd40b0870c70a8c11d1f4945c325c14343e53d7.zip
clean up uClibc config handling - use kconfig.pl to split configs similar to how it's done in the kernel
SVN-Revision: 15004
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index f5bfa2f3f4..906767da22 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -86,6 +86,8 @@ define Host/Prepare/V_0_9_28
endif
endef
+GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+
define Host/Prepare
$(call Host/SetToolchainInfo)
@echo prepare uClibc version $(PKG_VERSION)$(PKG_EXTRAVERSION)
@@ -95,7 +97,7 @@ define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(PKG_NAME)-$(PKG_VERSION)$(PKG_EXTRAVERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
endif
- $(CP) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD)) $(HOST_BUILD_DIR)/.config
+ $(GEN_CONFIG) > $(HOST_BUILD_DIR)/.config
ifeq ($(PKG_VERSION),0.9.28)
$(call Host/Prepare/V_0_9_28)
endif