aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-11-22 17:50:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-11-22 17:50:01 +0000
commitbccdd525198d3a0ba48645cc8bc61caef9cb9302 (patch)
treee129880275e839c13c3b52abdb6ff530460c454e /toolchain/uClibc/Makefile
parent90d140c9421654df762c16c72c75fc0071fb3383 (diff)
downloadupstream-bccdd525198d3a0ba48645cc8bc61caef9cb9302.tar.gz
upstream-bccdd525198d3a0ba48645cc8bc61caef9cb9302.tar.bz2
upstream-bccdd525198d3a0ba48645cc8bc61caef9cb9302.zip
uClibc: fix headers install on prepare with QUILT=1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24100 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 0b6f205380..0df26d097f 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -68,6 +68,12 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
define Host/Prepare
$(call Host/SetToolchainInfo)
$(call Host/Prepare/Default)
+ $(if $(strip $(QUILT)), \
+ cd $(HOST_BUILD_DIR); \
+ if $(QUILT_CMD) next >/dev/null 2>&1; then \
+ $(QUILT_CMD) push -a; \
+ fi
+ )
ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(GEN_CONFIG) > $(HOST_BUILD_DIR)/.config
$(SED) 's,^KERNEL_HEADERS=.*,KERNEL_HEADERS=\"$(BUILD_DIR_TOOLCHAIN)/linux-dev/include\",g' \