aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-06-26 14:22:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-06-26 14:22:55 +0000
commit0b4c80a1c45d37f0db18b454568f0667ddfc05ef (patch)
tree7bcaadfe39b47834e30eabb5e211809b53df26bd /toolchain/uClibc/Makefile
parent08f272b0490b27017e13b9098447e909563e3413 (diff)
downloadupstream-0b4c80a1c45d37f0db18b454568f0667ddfc05ef.tar.gz
upstream-0b4c80a1c45d37f0db18b454568f0667ddfc05ef.tar.bz2
upstream-0b4c80a1c45d37f0db18b454568f0667ddfc05ef.zip
uclibc: make powerpc e500 support independent of the target name, always use it if the spe_fpu feature flag is set
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27289 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 21a180c225..d74d1ecfc8 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -59,7 +59,9 @@ endef
GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
$(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) \
$(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
- $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+ $(CONFIG_DIR)/$(ARCH)$(strip \
+ $(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD), \
+ $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500))))
define Host/Prepare
$(call Host/Prepare/Default)