aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-29 11:56:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-29 11:56:27 +0000
commitd28bd2e3db2e17e92650faedd0dc2eb1a1fd3348 (patch)
tree9d8d0618b68127d8f28ce34c7903239ab63711b7 /toolchain/uClibc/Makefile
parentdd9b53b7174d1d70e19dab6be1de785099ee251c (diff)
downloadupstream-d28bd2e3db2e17e92650faedd0dc2eb1a1fd3348.tar.gz
upstream-d28bd2e3db2e17e92650faedd0dc2eb1a1fd3348.tar.bz2
upstream-d28bd2e3db2e17e92650faedd0dc2eb1a1fd3348.zip
uclibc: to rebuild libc.so.0, mklibs.py needs access to libc_so.a which was not exported by default. use it instead of libc_pic.a
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17438 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 1b8723f678..7206df2720 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -102,6 +102,7 @@ define Host/Compile
$(UCLIBC_MAKE) PREFIX= all
$(UCLIBC_MAKE) PREFIX="$(TOOLCHAIN_DIR)/" install_runtime install_dev
ln -sf ../../lib/libc.so.0 $(TOOLCHAIN_DIR)/usr/lib/libc.so
+ $(CP) $(HOST_BUILD_DIR)/libc/libc_so.a $(TOOLCHAIN_DIR)/usr/lib/
# ( cd $(TOOLCHAIN_DIR) ; \
# for d in lib usr/lib ; do \
# for f in libc.so libpthread.so libgcc_s.so ; do \