aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-24 01:34:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-24 01:34:51 +0000
commit44e5cd22197682cf4f48512f4e70a46db6dca589 (patch)
treeea12de91a33e737d95f7c55bbe8f0ea7739b940e /toolchain/uClibc/Makefile
parent8100c1727e3aeefaba7407f4edb38b7d0fba317f (diff)
downloadupstream-44e5cd22197682cf4f48512f4e70a46db6dca589.tar.gz
upstream-44e5cd22197682cf4f48512f4e70a46db6dca589.tar.bz2
upstream-44e5cd22197682cf4f48512f4e70a46db6dca589.zip
clean up uClibc config handling - use kconfig.pl to split configs similar to how it's done in the kernel
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15004 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc/Makefile')
-rw-r--r--toolchain/uClibc/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index f5bfa2f3f4..906767da22 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -86,6 +86,8 @@ define Host/Prepare/V_0_9_28
endif
endef
+GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+
define Host/Prepare
$(call Host/SetToolchainInfo)
@echo prepare uClibc version $(PKG_VERSION)$(PKG_EXTRAVERSION)
@@ -95,7 +97,7 @@ define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(PKG_NAME)-$(PKG_VERSION)$(PKG_EXTRAVERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
endif
- $(CP) ./$(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD)) $(HOST_BUILD_DIR)/.config
+ $(GEN_CONFIG) > $(HOST_BUILD_DIR)/.config
ifeq ($(PKG_VERSION),0.9.28)
$(call Host/Prepare/V_0_9_28)
endif