aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/patches-0.9.11
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-02-24 21:10:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-02-24 21:10:11 +0000
commit58d22ab8a4b1cb33ed55a1600270f6cbadfd98f8 (patch)
tree3890efe869cec8c18e3c5d1290deccaffec3f56b /toolchain/musl/patches-0.9.11
parent2c60412f00cbf5d2877e7041fd7c672ebe21fb6e (diff)
downloadupstream-58d22ab8a4b1cb33ed55a1600270f6cbadfd98f8.tar.gz
upstream-58d22ab8a4b1cb33ed55a1600270f6cbadfd98f8.tar.bz2
upstream-58d22ab8a4b1cb33ed55a1600270f6cbadfd98f8.zip
toolchain/musl: add version 0.9.15, remove older versions (still broken, but closer to being functional than before)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39750 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/musl/patches-0.9.11')
-rw-r--r--toolchain/musl/patches-0.9.11/000-install_portability.patch27
-rw-r--r--toolchain/musl/patches-0.9.11/100-wchar_include.patch60
-rw-r--r--toolchain/musl/patches-0.9.11/120-in_h_are_4_equal_parenthesis.patch11
-rw-r--r--toolchain/musl/patches-0.9.11/130-syslog_log_upto_parenthesis.patch11
4 files changed, 0 insertions, 109 deletions
diff --git a/toolchain/musl/patches-0.9.11/000-install_portability.patch b/toolchain/musl/patches-0.9.11/000-install_portability.patch
deleted file mode 100644
index 43c43519d9..0000000000
--- a/toolchain/musl/patches-0.9.11/000-install_portability.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -116,16 +116,20 @@
- chmod +x $@
-
- $(DESTDIR)$(bindir)/%: tools/%
-- install -D $< $@
-+ mkdir -p $(dir $@)
-+ install $< $@
-
- $(DESTDIR)$(libdir)/%.so: lib/%.so
-- install -D -m 755 $< $@
-+ mkdir -p $(dir $@)
-+ install -m 755 $< $@
-
- $(DESTDIR)$(libdir)/%: lib/%
-- install -D -m 644 $< $@
-+ mkdir -p $(dir $@)
-+ install -m 644 $< $@
-
- $(DESTDIR)$(includedir)/%: include/%
-- install -D -m 644 $< $@
-+ mkdir -p $(dir $@)
-+ install -m 644 $< $@
-
- $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(syslibdir)
- ln -sf $(libdir)/libc.so $@ || true
diff --git a/toolchain/musl/patches-0.9.11/100-wchar_include.patch b/toolchain/musl/patches-0.9.11/100-wchar_include.patch
deleted file mode 100644
index 5d78ced6a9..0000000000
--- a/toolchain/musl/patches-0.9.11/100-wchar_include.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/arch/arm/bits/alltypes.h.sh
-+++ b/arch/arm/bits/alltypes.h.sh
-@@ -22,6 +22,7 @@
-
- TYPEDEF __builtin_va_list va_list;
- TYPEDEF __builtin_va_list __isoc_va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF unsigned wchar_t;
---- a/arch/i386/bits/alltypes.h.sh
-+++ b/arch/i386/bits/alltypes.h.sh
-@@ -27,6 +27,7 @@
- TYPEDEF struct __va_list * va_list;
- TYPEDEF struct __va_list * __isoc_va_list;
- #endif
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- #ifdef __WCHAR_TYPE__
---- a/arch/microblaze/bits/alltypes.h.sh
-+++ b/arch/microblaze/bits/alltypes.h.sh
-@@ -22,6 +22,7 @@
-
- TYPEDEF __builtin_va_list va_list;
- TYPEDEF __builtin_va_list __isoc_va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF int wchar_t;
---- a/arch/mips/bits/alltypes.h.sh
-+++ b/arch/mips/bits/alltypes.h.sh
-@@ -22,6 +22,7 @@
-
- TYPEDEF __builtin_va_list va_list;
- TYPEDEF __builtin_va_list __isoc_va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF int wchar_t;
---- a/arch/powerpc/bits/alltypes.h.sh
-+++ b/arch/powerpc/bits/alltypes.h.sh
-@@ -22,6 +22,7 @@
-
- TYPEDEF __builtin_va_list va_list;
- TYPEDEF __builtin_va_list __isoc_va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF long wchar_t;
---- a/arch/x86_64/bits/alltypes.h.sh
-+++ b/arch/x86_64/bits/alltypes.h.sh
-@@ -21,6 +21,7 @@
- TYPEDEF long ptrdiff_t;
- TYPEDEF __builtin_va_list va_list;
- TYPEDEF __builtin_va_list __isoc_va_list;
-+#define __gnuc_va_list va_list
-
- #ifndef __cplusplus
- TYPEDEF int wchar_t;
diff --git a/toolchain/musl/patches-0.9.11/120-in_h_are_4_equal_parenthesis.patch b/toolchain/musl/patches-0.9.11/120-in_h_are_4_equal_parenthesis.patch
deleted file mode 100644
index 8b5dbd4426..0000000000
--- a/toolchain/musl/patches-0.9.11/120-in_h_are_4_equal_parenthesis.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/netinet/in.h
-+++ b/include/netinet/in.h
-@@ -146,7 +146,7 @@ uint16_t ntohs(uint16_t);
- (IN6_IS_ADDR_MULTICAST(a) && ((((uint8_t *) (a))[1] & 0xf) == 0xe))
-
- #define __ARE_4_EQUAL(a,b) \
-- (!( 0[a]-0[b] | 1[a]-1[b] | 2[a]-2[b] | 3[a]-3[b] ))
-+ (!( (0[a]-0[b]) | (1[a]-1[b]) | (2[a]-2[b]) | (3[a]-3[b]) ))
- #define IN6_ARE_ADDR_EQUAL(a,b) \
- __ARE_4_EQUAL((const uint32_t *)(a), (const uint32_t *)(b))
-
diff --git a/toolchain/musl/patches-0.9.11/130-syslog_log_upto_parenthesis.patch b/toolchain/musl/patches-0.9.11/130-syslog_log_upto_parenthesis.patch
deleted file mode 100644
index 840dd40132..0000000000
--- a/toolchain/musl/patches-0.9.11/130-syslog_log_upto_parenthesis.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/syslog.h
-+++ b/include/syslog.h
-@@ -21,7 +21,7 @@ extern "C" {
- #define LOG_MAKEPRI(f, p) (((f)<<3)|(p))
-
- #define LOG_MASK(p) (1<<(p))
--#define LOG_UPTO(p) ((1<<(p)+1)-1)
-+#define LOG_UPTO(p) ((1<<((p)+1))-1)
-
- #define LOG_KERN (0<<3)
- #define LOG_USER (1<<3)