aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/patches-0.9.11/000-install_portability.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-07-04 21:26:01 +0000
committerLuka Perkov <luka@openwrt.org>2013-07-04 21:26:01 +0000
commit00b5a145677ac890f694898a8d095ad10574abdb (patch)
tree5028daa24ec346ccc894e7f333ca4206c96cfc4e /toolchain/musl/patches-0.9.11/000-install_portability.patch
parent4aa82d07a6806adf94b47154869c8a630eabb723 (diff)
downloadupstream-00b5a145677ac890f694898a8d095ad10574abdb.tar.gz
upstream-00b5a145677ac890f694898a8d095ad10574abdb.tar.bz2
upstream-00b5a145677ac890f694898a8d095ad10574abdb.zip
toolchain/musl: add version 0.9.11
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 37173
Diffstat (limited to 'toolchain/musl/patches-0.9.11/000-install_portability.patch')
-rw-r--r--toolchain/musl/patches-0.9.11/000-install_portability.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/toolchain/musl/patches-0.9.11/000-install_portability.patch b/toolchain/musl/patches-0.9.11/000-install_portability.patch
new file mode 100644
index 0000000000..43c43519d9
--- /dev/null
+++ b/toolchain/musl/patches-0.9.11/000-install_portability.patch
@@ -0,0 +1,27 @@
+--- a/Makefile
++++ b/Makefile
+@@ -116,16 +116,20 @@
+ chmod +x $@
+
+ $(DESTDIR)$(bindir)/%: tools/%
+- install -D $< $@
++ mkdir -p $(dir $@)
++ install $< $@
+
+ $(DESTDIR)$(libdir)/%.so: lib/%.so
+- install -D -m 755 $< $@
++ mkdir -p $(dir $@)
++ install -m 755 $< $@
+
+ $(DESTDIR)$(libdir)/%: lib/%
+- install -D -m 644 $< $@
++ mkdir -p $(dir $@)
++ install -m 644 $< $@
+
+ $(DESTDIR)$(includedir)/%: include/%
+- install -D -m 644 $< $@
++ mkdir -p $(dir $@)
++ install -m 644 $< $@
+
+ $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(syslibdir)
+ ln -sf $(libdir)/libc.so $@ || true