aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/common.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2017-01-03 17:51:04 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-16 20:40:00 +0100
commita8a5cb9595cd64a48c1cea6a1478c11e022474a9 (patch)
treeea0417332a8bbea1bc2b1d2e810044558c54da51 /toolchain/musl/common.mk
parentda5d060ac9171029cfde61ee45aa417696e45da0 (diff)
downloadupstream-a8a5cb9595cd64a48c1cea6a1478c11e022474a9.tar.gz
upstream-a8a5cb9595cd64a48c1cea6a1478c11e022474a9.tar.bz2
upstream-a8a5cb9595cd64a48c1cea6a1478c11e022474a9.zip
musl: update musl to 1.1.16+ and switch to download from git
This patch updates musl to 1.1.16+ [0] and removes all the backported patches. This is a major release and tagged as such. For more information visit musl-libc.org or read the WHATSNEW. Furthermore, this patch also changes musl to download directly from git. This makes it easier to update musl in the future. The patch custom Add-format-attribute-to-some-function-declarations.patch was assigned a new 400- number. This should avoid confusion since 0xx numbers are usually assigned to backports. [0] <http://git.musl-libc.org/cgit/musl/commit/?id=769f53598e781ffc89191520f3f8a93cb58db91f> Cc: Hannu Nyman <hannu.nyman@iki.fi> Cc: Koen Vandeputte <koen.vandeputte@ncentric.com> Cc: Jo-Philipp Wich <jo@mein.io> Cc: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
Diffstat (limited to 'toolchain/musl/common.mk')
-rw-r--r--toolchain/musl/common.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 9f3f7add4d..bfe8eebc7b 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -11,10 +11,13 @@ PKG_NAME:=musl
PKG_VERSION:=$(call qstrip,$(CONFIG_MUSL_VERSION))
PKG_RELEASE=1
-PKG_HASH:=97e447c7ee2a7f613186ec54a93054fe15469fe34d7d323080f7ef38f5ecb0fa
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=769f53598e781ffc89191520f3f8a93cb58db91f
+PKG_MIRROR_HASH:=c148c570cc46471ab30a1b36e96531519837e41c4347f3164bf610ab98741d80
+PKG_SOURCE_URL:=git://git.musl-libc.org/musl
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
-PKG_SOURCE_URL:=http://www.musl-libc.org/releases
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
LIBC_SO_VERSION:=$(PKG_VERSION)
PATCH_DIR:=$(PATH_PREFIX)/patches