aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/common.mk
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-08-13 03:01:07 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 17:23:17 +0200
commit5e3b21c91647f72e73a550f3059fa7ea8146759f (patch)
tree6b6d000fa65fbe64b3daf9582f218c35535c8058 /toolchain/musl/common.mk
parent2df2b75208dce06dee02508c8d589fc5f540023d (diff)
downloadupstream-5e3b21c91647f72e73a550f3059fa7ea8146759f.tar.gz
upstream-5e3b21c91647f72e73a550f3059fa7ea8146759f.tar.bz2
upstream-5e3b21c91647f72e73a550f3059fa7ea8146759f.zip
musl: ldso/dlsym: fix mips returning undef dlsym
This happens only the second time a library is loaded by dlopen(). After lib1 is loaded, dlsym(lib1,"undef1") correctly resolves the undef symbol from lib1 dependencies. After the second library is loaded, dlsym(lib2,"undef1") was returning the address of "undef1" in lib2 instead of searching lib2 dependencies. Backporting upstream fix which now uses the same logic for relocation time and dlsym. Fixes openwrt/packages#9297 Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'toolchain/musl/common.mk')
-rw-r--r--toolchain/musl/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 87424646c3..93049479b2 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/target.mk
PKG_NAME:=musl
PKG_VERSION:=1.1.19
-PKG_RELEASE=1
+PKG_RELEASE=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)