aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/insight/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-03 15:01:03 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-25 19:01:07 +0200
commitf62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b (patch)
tree96563a32e7c0f1b7d96bae85defb7f17bae626ec /toolchain/insight/Makefile
parenta76cbc0d7ec2a816682063bdc18d114ec0711113 (diff)
downloadupstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.tar.gz
upstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.tar.bz2
upstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.zip
build: stop overriding STAGING_DIR_HOST for toolchain build
This causes various issues in other places that assume that host binaries are staged in STAGING_DIR_HOST. Since all the right places use HOST_BUILD_PREFIX, override that instead. This fixes some issues with quilt on toolchain dirs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/insight/Makefile')
-rw-r--r--toolchain/insight/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/toolchain/insight/Makefile b/toolchain/insight/Makefile
index 60309ba094..63a0e27ced 100644
--- a/toolchain/insight/Makefile
+++ b/toolchain/insight/Makefile
@@ -14,10 +14,7 @@ PKG_HASH:=51216df73adc4f68c67b60356270d5073f0ff094c1b477ecd96560f49707ea2a
PKG_SOURCE_URL:=ftp://sourceware.org/pub/insight/releases
PKG_CAT:=bzcat
-STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
-BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
-
-include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/toolchain-build.mk
define Host/Configure
(cd $(HOST_BUILD_DIR); \