aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/patches/2.14
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-02-12 16:12:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-02-12 16:12:01 +0000
commit07488ef93d4c2cff5e981dca1bec71747bebc5b0 (patch)
treed8396705821e83118ef0b211a07b0f7a7ffc6669 /toolchain/glibc/patches/2.14
parentfd74a50df75b6f1288f217e45046032a379e4221 (diff)
downloadupstream-07488ef93d4c2cff5e981dca1bec71747bebc5b0.tar.gz
upstream-07488ef93d4c2cff5e981dca1bec71747bebc5b0.tar.bz2
upstream-07488ef93d4c2cff5e981dca1bec71747bebc5b0.zip
glibc: remove all previous (ancient) versions, add 2.14 (partially based on a patch and testing by WillieNL)
SVN-Revision: 30478
Diffstat (limited to 'toolchain/glibc/patches/2.14')
-rw-r--r--toolchain/glibc/patches/2.14/100-fix_cpuid_h_check.patch22
-rw-r--r--toolchain/glibc/patches/2.14/200-add_dl_search_path.patch12
2 files changed, 34 insertions, 0 deletions
diff --git a/toolchain/glibc/patches/2.14/100-fix_cpuid_h_check.patch b/toolchain/glibc/patches/2.14/100-fix_cpuid_h_check.patch
new file mode 100644
index 0000000000..12d0e1e996
--- /dev/null
+++ b/toolchain/glibc/patches/2.14/100-fix_cpuid_h_check.patch
@@ -0,0 +1,22 @@
+--- a/sysdeps/i386/configure.in
++++ b/sysdeps/i386/configure.in
+@@ -2,7 +2,7 @@
+ # Local configure fragment for sysdeps/i386.
+
+ AC_HEADER_CHECK([cpuid.h], ,
+- [AC_MSG_ERROR([gcc must provide the <cpuid.h> header])])
++ [AC_MSG_ERROR([gcc must provide the <cpuid.h> header])], [])
+
+ AC_CACHE_CHECK(if -g produces usable source locations for assembler-with-cpp,
+ libc_cv_cpp_asm_debuginfo, [dnl
+--- a/sysdeps/i386/configure
++++ b/sysdeps/i386/configure
+@@ -632,7 +632,7 @@
+ done
+
+
+-ac_fn_c_check_header_mongrel "$LINENO" "cpuid.h" "ac_cv_header_cpuid_h" "$ac_includes_default"
++ac_fn_c_check_header_mongrel "$LINENO" "cpuid.h" "ac_cv_header_cpuid_h" ""
+ if test "x$ac_cv_header_cpuid_h" = x""yes; then :
+
+ else
diff --git a/toolchain/glibc/patches/2.14/200-add_dl_search_path.patch b/toolchain/glibc/patches/2.14/200-add_dl_search_path.patch
new file mode 100644
index 0000000000..2f4a48f201
--- /dev/null
+++ b/toolchain/glibc/patches/2.14/200-add_dl_search_path.patch
@@ -0,0 +1,12 @@
+--- a/Makeconfig
++++ b/Makeconfig
+@@ -529,6 +529,9 @@
+ default-rpath = $(libdir)
+ endif
+
++# Add /usr/lib to default search path for the dynamic linker
++user-defined-trusted-dirs := /usr/lib
++
+ ifndef link-extra-libs
+ link-extra-libs = $(LDLIBS-$(@F))
+ link-extra-libs-static = $(link-extra-libs)