aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/headers
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-12 19:50:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-12 19:50:57 +0000
commitd5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8 (patch)
tree5236aa6a2ac180eacc86c1739a57f41619119077 /toolchain/glibc/headers
parenta00f7e5cb5fbb3dd1486a3623d2b3428a6b07a79 (diff)
downloadupstream-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.tar.gz
upstream-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.tar.bz2
upstream-d5f527f3cee5cec5744d2a6f3ccd2cdae7adaca8.zip
toolchain: The glorious return of glibc, ver 2.21
It's the eglibc packaging with a bit of spit-polishing. And testing. :-) [blogic: merged glibc and eglibc into 1 and made eglibc a glibc variant] Signed-off-by: Jeff Waugh <jdub@bethesignal.org> Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44701 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/glibc/headers')
-rw-r--r--toolchain/glibc/headers/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/toolchain/glibc/headers/Makefile b/toolchain/glibc/headers/Makefile
new file mode 100644
index 0000000000..f9f411b1f0
--- /dev/null
+++ b/toolchain/glibc/headers/Makefile
@@ -0,0 +1,27 @@
+PATH_PREFIX:=..
+VARIANT:=headers
+
+include ../common.mk
+
+define Host/Compile
+
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/{include,lib}
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ BUILD_CFLAGS="$(HOST_CFLAGS)" \
+ install_root="$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev" \
+ install-bootstrap-headers=yes \
+ install-headers
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ csu/subdir_lib
+ ( cd $(CUR_BUILD_DIR); \
+ $(CP) csu/crt1.o csu/crti.o csu/crtn.o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/ \
+ )
+ $(TARGET_CC) -nostdlib -nostartfiles -shared -x c /dev/null \
+ -o $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev/lib/libc.so
+endef
+
+$(eval $(call HostBuild))