aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc-ports/Makefile
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2012-04-28 22:24:12 +0000
committerMirko Vogt <mirko@openwrt.org>2012-04-28 22:24:12 +0000
commit334fd4199b94bddd3b17eaa93668e9f04f004ee0 (patch)
tree674661fe3699b36eae14bec14f39d0f5989da02e /toolchain/glibc-ports/Makefile
parent6831c99f65e1d731d1916c58b29e6254d369620e (diff)
downloadupstream-334fd4199b94bddd3b17eaa93668e9f04f004ee0.tar.gz
upstream-334fd4199b94bddd3b17eaa93668e9f04f004ee0.tar.bz2
upstream-334fd4199b94bddd3b17eaa93668e9f04f004ee0.zip
purge support for glibc - use eglibc instead!
for reference: http://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg13425.html SVN-Revision: 31503
Diffstat (limited to 'toolchain/glibc-ports/Makefile')
-rw-r--r--toolchain/glibc-ports/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/toolchain/glibc-ports/Makefile b/toolchain/glibc-ports/Makefile
deleted file mode 100644
index c95709cc9a..0000000000
--- a/toolchain/glibc-ports/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=glibc-ports
-PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-
-ifeq ($(PKG_VERSION),2.3.6)
- PKG_MD5SUM:=40dce745d34ff80401da2fdfe58f6d53
-endif
-ifeq ($(PKG_VERSION),2.6.1)
- PKG_MD5SUM:=53d88ca624642dd267752ccce77b19d0
-endif
-ifeq ($(PKG_VERSION),2.7)
- PKG_MD5SUM:=eaeb8527b8fa286c2d887157214f9998
-endif
-
-PKG_SOURCE_URL:=@GNU/glibc/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-
-PATCH_DIR:=./patches/$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/toolchain-build.mk
-
-HOST_STAMP_BUILT:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_built
-HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_installed
-
-define Host/Prepare
-$(call Host/Prepare/Default)
- ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
-endef
-
-define Host/Configure
-endef
-
-define Host/Compile
-endef
-
-define Host/Install
-endef
-
-define Host/Clean
- rm -rf \
- $(HOST_BUILD_DIR) \
- $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
-endef
-
-$(eval $(call HostBuild))